Vulnerability · Published May 12, 2026 · Assigned by GitHub_M
CVE-2026-44166Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade
Medium 6.1
In plain English
A medium-severity improper authentication in pocketbase from pocketbase. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/pocketbase/pocketbase | 0.22.42 | GHSA-pq7p-mc74-g65w |
| Go | github.com/pocketbase/pocketbase | 0.37.4 | GHSA-pq7p-mc74-g65w |
| Go | github.com/pocketbase/pocketbase | 0.22.42, 0.37.4 | GO-2026-5548 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| pocketbase | pocketbase | < 0.22.42>= 0.30.0, < 0.37.4 |
Weakness: CWE-287 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/pocketbase/pocketbase/security/advisories/GHSA-pq7p-mc74-g65w x_refsource_CONFIRM