Vulnerability · Published May 5, 2026 · Assigned by apache
CVE-2026-43870Apache Thrift: Node.js web_server.js multi-vulnerability
High 7.3
In plain English
A high-severity path traversal in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | thrift | no fix listed | DEBIAN-CVE-2026-43870 |
| Debian:13 | thrift | no fix listed | DEBIAN-CVE-2026-43870 |
| Debian:14 | thrift | 0.23.0-3 | DEBIAN-CVE-2026-43870 |
| Ubuntu:22.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-43870 |
| Ubuntu:24.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-43870 |
| Ubuntu:25.10 | thrift | no fix listed | UBUNTU-CVE-2026-43870 |
| Ubuntu:26.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-43870 |
| Ubuntu:26.10 | thrift | no fix listed | UBUNTU-CVE-2026-43870 |
| npm | thrift | no fix listed | GHSA-526f-jxpj-jmg2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Thrift | 0 – before 0.23.0 |
Weakness: CWE-346, CWE-22, CWE-113, CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L