Vulnerability · Published Jun 29, 2026 · Assigned by apple

CVE-2026-43701

High 7.1

In plain English

A high-severity improper access control in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.6%top 53.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The issue was addressed with improved checks. This issue is fixed in Safari 26.5.2, iOS 18.7.10 and iPadOS 18.7.10, iOS 26.5.2 and iPadOS 26.5.2, macOS Tahoe 26.5.2, tvOS 26.6, visionOS 26.6, watchOS 26.6. A malicious website may be able to process restricted web content outside the sandbox.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.52.5-1.el8_10ALSA-2026:42088
AlmaLinux:9webkit2gtk32.52.5-1.el9_8ALSA-2026:42062
AlmaLinux:8webkit2gtk3-devel2.52.5-1.el8_10ALSA-2026:42088
AlmaLinux:9webkit2gtk3-devel2.52.5-1.el9_8ALSA-2026:42062
AlmaLinux:8webkit2gtk3-jsc2.52.5-1.el8_10ALSA-2026:42088
AlmaLinux:9webkit2gtk3-jsc2.52.5-1.el9_8ALSA-2026:42062
AlmaLinux:8webkit2gtk3-jsc-devel2.52.5-1.el8_10ALSA-2026:42088
AlmaLinux:9webkit2gtk3-jsc-devel2.52.5-1.el9_8ALSA-2026:42062
Debian:12webkit2gtkno fix listedDEBIAN-CVE-2026-43701
Debian:13webkit2gtk2.52.5-1~deb13u1DEBIAN-CVE-2026-43701
Debian:14webkit2gtk2.52.5-1DEBIAN-CVE-2026-43701
Debian:12wpewebkitno fix listedDEBIAN-CVE-2026-43701
Debian:13wpewebkitno fix listedDEBIAN-CVE-2026-43701
Debian:14wpewebkit2.52.5-1DEBIAN-CVE-2026-43701
Rocky Linux:8webkit2gtk30:2.52.5-1.el8_10RLSA-2026:42088
Rocky Linux:9webkit2gtk30:2.52.5-1.el9_8RLSA-2026:42062
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2026-43701
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2026-43701
Ubuntu:22.04:LTSwebkit2gtkno fix listedUBUNTU-CVE-2026-43701
Ubuntu:24.04:LTSwebkit2gtk2.52.6-0ubuntu0.24.04.1USN-8703-1
Ubuntu:24.04:LTSwebkit2gtk2.52.6-0ubuntu0.24.04.1UBUNTU-CVE-2026-43701
Ubuntu:26.04:LTSwebkit2gtk2.52.6-0ubuntu0.26.04.1USN-8703-1
Ubuntu:26.04:LTSwebkit2gtk2.52.6-0ubuntu0.26.04.1UBUNTU-CVE-2026-43701
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2026-43701

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 26.5.2
Apple iOS and iPadOS 0 – before 18.7.100 – before 26.5.2
Apple macOS 0 – before 26.5.2
Apple tvOS 0 – before 26.6
Apple visionOS 0 – before 26.6
Apple watchOS 0 – before 26.6

Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L

References