Vulnerability · Published May 5, 2026 · Assigned by mitre

CVE-2026-42997

High 7.7

In plain English

A high-severity security flaw in Ironic from OpenStack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)0.4%top 62.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

An issue was discovered in idrac in OpenStack Ironic before 35.0.1. During import, a user invoking molds can request authorization to be sent to a remote endpoint. The credential forwarded is a time-limited Keystone token (which provides access to all OpenStack services Ironic is authorized for); or basic credentials configured for molds storage. The fixed versions are 26.1.6, 29.0.5, 32.0.1, and 35.0.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ironic1:21.1.0-3+deb12u1DEBIAN-CVE-2026-42997
Debian:13ironic1:29.0.5-0+deb13u1DEBIAN-CVE-2026-42997
Debian:14ironic1:35.0.1-1DEBIAN-CVE-2026-42997
PyPIironic-python-agent32.0.1GHSA-54w4-233h-x86g
PyPIironic-python-agent35.0.1GHSA-54w4-233h-x86g
PyPIironic-python-agent29.0.5GHSA-54w4-233h-x86g
PyPIironic-python-agent26.1.6GHSA-54w4-233h-x86g
PyPIironic-python-agent26.1.6, 29.0.5, 32.0.1, 35.0.1PYSEC-2026-2526
Ubuntu:22.04:LTSironicno fix listedUBUNTU-CVE-2026-42997
Ubuntu:24.04:LTSironicno fix listedUBUNTU-CVE-2026-42997
Ubuntu:25.10ironicno fix listedUBUNTU-CVE-2026-42997
Ubuntu:26.04:LTSironicno fix listedUBUNTU-CVE-2026-42997
Ubuntu:26.10ironicno fix listedUBUNTU-CVE-2026-42997

Affected products (as reported)

VendorProductVersions
OpenStack Ironic 17.0.0 – before 26.1.627.0.0 – before 29.0.530.0.0 – before 32.0.133.0.0 – before 35.0.1

Weakness: CWE-669, CWE-201 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

References