Vulnerability · Published May 25, 2026 · Assigned by apache
CVE-2026-42797Apache Syncope: JexlContextBuilder Information Disclosure
Medium 4.9
In plain English
A medium-severity security flaw in Apache Syncope from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.syncope.core:syncope-core-provisioning-api | no fix listed | GHSA-vr35-jm2f-8wg2 |
| Maven | org.apache.syncope.core:syncope-core-provisioning-api | 4.0.6 | GHSA-vr35-jm2f-8wg2 |
| Maven | org.apache.syncope.core:syncope-core-provisioning-api | 4.1.1 | GHSA-vr35-jm2f-8wg2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Syncope | 3.0 – through 3.0.164.0 – through 4.0.54.1 – through 4.1.0 |
Weakness: CWE-202 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N