Vulnerability · Published May 13, 2026 · Assigned by GitHub_M
CVE-2026-42580Netty: HTTP Request Smuggling due to incorrect chunk size parsing
Medium 6.5
In plain English
A medium-severity integer overflow in netty-codec-http from io.netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 68.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known
Official description
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, Netty's chunk size parser silently overflows int, enabling request smuggling attacks. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | netty | no fix listed | DEBIAN-CVE-2026-42580 |
| Debian:13 | netty | no fix listed | DEBIAN-CVE-2026-42580 |
| Debian:14 | netty | no fix listed | DEBIAN-CVE-2026-42580 |
| Maven | io.netty:netty-codec-http | 4.1.133.Final | GHSA-m4cv-j2px-7723 |
| Maven | io.netty:netty-codec-http | 4.2.13.Final | GHSA-m4cv-j2px-7723 |
| Ubuntu:25.10 | netty | no fix listed | UBUNTU-CVE-2026-42580 |
| Ubuntu:26.10 | netty | no fix listed | UBUNTU-CVE-2026-42580 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| netty | netty | >= 4.2.0.Alpha1, < 4.2.13.Final< 4.1.133.Final |
| io.netty | netty-codec-http | >= 4.2.0.Alpha1, < 4.2.13.Final< 4.1.133.Final |
Weakness: CWE-444, CWE-190 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
References
- https://github.com/netty/netty/security/advisories/GHSA-m4cv-j2px-7723 x_refsource_CONFIRM