Vulnerability · Published May 8, 2026 · Assigned by GitHub_M
CVE-2026-42556Postiz stored XSS in public preview page
High 8.9
In plain English
A high-severity cross-site scripting in postiz-app from gitroomhq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities).
Official description
Postiz is an AI social media scheduling tool. From version 2.21.6 to before version 2.21.7, any authenticated user who can create a post can store arbitrary HTML in post content by tampering their own save request and send the public preview link /p/<postId>?share=true to another user. The preview page renders that stored HTML with dangerouslySetInnerHTML on the main application origin. This issue has been patched in version 2.21.7.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| gitroomhq | postiz-app | >= 2.21.6, < 2.21.7 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L
References
- https://github.com/gitroomhq/postiz-app/security/advisories/GHSA-hhxq-3wg7-4rj8 x_refsource_CONFIRM
- https://github.com/gitroomhq/postiz-app/releases/tag/v2.21.7 x_refsource_MISC