Vulnerability · Published May 13, 2026 · Assigned by GitHub_M
CVE-2026-42552Flight: Sensitive information disclosure via default error handler in flightphp/core
High 7.5
In plain English
A high-severity security flaw in core from flightphp. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flight is an extensible micro-framework for PHP. Prior to 3.18.1, the default error handler Engine::_error() writes the full exception message, exception code, and stack trace (including absolute filesystem paths) directly into the HTTP 500 response, with no debug gating. Production deployments leak internal paths, any secret interpolated into an exception message, and full module structure — giving attackers primitives for chaining other weaknesses (LFI, path traversal). This vulnerability is fixed in 3.18.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | flightphp/core | 3.18.1 | GHSA-qrch-52m5-vv85 |
Affected products (as reported)
Weakness: CWE-209 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/flightphp/core/security/advisories/GHSA-qrch-52m5-vv85 x_refsource_CONFIRM