Vulnerability · Published May 13, 2026 · Assigned by GitHub_M
CVE-2026-42548Flight: Reflected XSS via unvalidated JSONP callback in Flight::jsonp()
High 8.6
In plain English
A high-severity cross-site scripting in core from flightphp. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flight is an extensible micro-framework for PHP. Prior to 3.18.1, Flight::jsonp() concatenates the ?jsonp= query parameter directly into an application/javascript response body without validating that the value is a legal JavaScript identifier. An attacker can inject arbitrary JavaScript that executes in the response origin, enabling reflected cross-site scripting. This vulnerability is fixed in 3.18.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | flightphp/core | 3.18.1 | GHSA-fcx8-ph5r-mxr4 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N
References
- https://github.com/flightphp/core/security/advisories/GHSA-fcx8-ph5r-mxr4 x_refsource_CONFIRM