Vulnerability · Published May 14, 2026 · Assigned by GitHub_M
CVE-2026-42334Mongoose: Improper Sanitization of $nor in sanitizeFilter May Allow NoSQL Injection
High 7.5
In plain English
A high-severity injection in mongoose from Automattic. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Mongoose is a MongoDB object modeling tool designed to work in an asynchronous environment. Prior to 6.13.9, 7.8.9, 8.22.1, and 9.1.6, a vulnerability allows bypassing Mongoose’s sanitizeFilter query sanitization mechanism via the $nor operator. When sanitizeFilter is enabled, Mongoose wraps query operators in $eq to neutralize them. However, prior to the fix, $nor was not included in the set of logical operators that are recursively sanitized. Because $nor accepts an array (like $and and $or), and arrays do not trigger hasDollarKeys(), malicious operators such as $ne, $gt, or $regex could be injected inside a $nor clause without being sanitized. This vulnerability is fixed in 6.13.9, 7.8.9, 8.22.1, and 9.1.6.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | mongoose | 6.13.9 | GHSA-wpg9-53fq-2r8h |
| npm | mongoose | 7.8.9 | GHSA-wpg9-53fq-2r8h |
| npm | mongoose | 8.22.1 | GHSA-wpg9-53fq-2r8h |
| npm | mongoose | 9.1.6 | GHSA-wpg9-53fq-2r8h |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Automattic | mongoose | < 6.13.9>= 7.0.0, <= 7.8.8>= 8.0.0, <= 8.22.0>= 9.0.0, <= 9.1.5 |
Weakness: CWE-74 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
References
- https://github.com/Automattic/mongoose/security/advisories/GHSA-wpg9-53fq-2r8h x_refsource_CONFIRM