Vulnerability · Published May 8, 2026 · Assigned by GitHub_M

CVE-2026-42307Vim: OS Command Injection in netrw

Medium 4.4

In plain English

A medium-severity OS command injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.4Medium
Exploit odds (30 days)0.8%top 44.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Vim is an open source, command line text editor. Prior to version 9.2.0383, an OS command injection vulnerability exists in the netrw standard plugin bundled with Vim. By inducing a user to open a crafted URL (e.g., using the sftp:// or file:// protocol handlers), an attacker can execute arbitrary shell commands with the privileges of the Vim process. This issue has been patched in version 9.2.0383.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23vim9.2.0389-r0ALPINE-CVE-2026-42307
Alpine:v3.24vim9.2.0389-r0ALPINE-CVE-2026-42307
Debian:12vimno fix listedDEBIAN-CVE-2026-42307
Debian:13vim2:9.1.1230-2+deb13u1DEBIAN-CVE-2026-42307
Debian:14vim2:9.2.0428-1DEBIAN-CVE-2026-42307
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.30USN-8304-1
Ubuntu:22.04:LTSvim2:8.2.3995-1ubuntu2.30UBUNTU-CVE-2026-42307
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.14USN-8304-1
Ubuntu:24.04:LTSvim2:9.1.0016-1ubuntu7.14UBUNTU-CVE-2026-42307
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.5USN-8304-1
Ubuntu:25.10vim2:9.1.0967-1ubuntu6.5UBUNTU-CVE-2026-42307
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.2UBUNTU-CVE-2026-42307
Ubuntu:26.04:LTSvim2:9.1.2141-1ubuntu4.2USN-8304-1

Affected products (as reported)

VendorProductVersions
vim vim < 9.2.0383

Weakness: CWE-78 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

References