Actively exploited · Published May 8, 2026 · Assigned by GitHub_M

CVE-2026-42271LiteLLM: Authenticated command execution via MCP stdio test endpoints

High 8.8 Exploited

In plain English

A high-severity command injection in litellm from BerriAI. Attackers are actively exploiting it in the wild (listed by CISA on June 8, 2026). The chance it is exploited in the next 30 days is estimated at 91.4% (higher than 99.8% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit, Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)91.4%top 0.2% of all CVEs
Exploited in the wildYesCISA KEV since Jun 8, 2026
Attack tooling3Metasploit, Nuclei, Public PoC

CISA guidance

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Federal agencies must remediate by Jun 22, 2026.

Official description

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIlitellm1.83.7GHSA-v4p8-mg3p-g94g
PyPIlitellm1.83.7PYSEC-2026-2599

Affected products (as reported)

VendorProductVersions
BerriAI litellm >= 1.74.2, < 1.83.7

Weakness: CWE-77, CWE-78 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References