Vulnerability · Published May 4, 2026 · Assigned by GitHub_M
CVE-2026-42235n8n: XSS via MCP OAuth client
High 8.8
In plain English
A high-severity cross-site scripting in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.32, 2.17.4, and 2.18.1, an unauthenticated attacker could register a malicious MCP OAuth client with a crafted client_name. If a victim user authorized the OAuth consent dialog and a second user subsequently revoked that access, a toast notification would render the injected script. Clicking the link would execute arbitrary JavaScript in the victim's authenticated n8n browser session, enabling credential and session token theft, workflow manipulation, or privilege escalation. This issue has been patched in versions 1.123.32, 2.17.4, and 2.18.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 1.123.32 | GHSA-537j-gqpc-p7fq |
| npm | n8n | 2.18.1 | GHSA-537j-gqpc-p7fq |
| npm | n8n | 2.17.4 | GHSA-537j-gqpc-p7fq |
Affected products (as reported)
Weakness: CWE-87, CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:L/SC:H/SI:H/SA:L
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-537j-gqpc-p7fq x_refsource_CONFIRM