Vulnerability · Published May 15, 2026 · Assigned by GitHub_M
CVE-2026-42155Magento LTS: Weak API Session ID — Predictable MD5 of Time-Derived Inputs
Critical 9.3
In plain English
A critical-severity weak randomness in magento-lts from OpenMage. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Magento Long Term Support (LTS) is an unofficial, community-driven project provides an alternative to the Magento Community Edition e-commerce platform with a high level of backward compatibility. Prior to 20.18.0, the XML-RPC / SOAP API session ID is generated using an outdated, time-based construction rather than a Cryptographically Secure Pseudo-Random Number Generator (CSPRNG). All inputs to the MD5 hash are time-derived and non-secure. Because the resulting digest relies entirely on the timestamp and the PHP internal LCG state, the effective entropy is severely constrained. This violates the OWASP ASVS v4 requirement of ≥ 64 bits of entropy (V3.2.2) and NIST SP 800-63B standards. By narrowing the LCG window (via server state leaks or general predictability) and leveraging the lack of API rate-limiting, an attacker can generate a localized pool of candidate MD5 hashes and execute a high-speed online brute-force attack to hijack active API sessions. This vulnerability is fixed in 20.18.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | openmage/magento-lts | 20.18.0 | GHSA-2cwr-gcf9-pvxr |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| OpenMage | magento-lts | < 20.18.0 |
Weakness: CWE-330, CWE-331, CWE-338 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-2cwr-gcf9-pvxr x_refsource_CONFIRM