Vulnerability · Published Apr 24, 2026 · Assigned by GitHub_M
CVE-2026-41907uuid: Missing buffer bounds check in `v3`/`v5`/`v6` when `buf` is provided
High 8.1
In plain English
A high-severity out-of-bounds write in uuid from uuidjs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
uuid is for the creation of RFC9562 (formerly RFC4122) UUIDs. Prior to 14.0.0, v3, v5, and v6 accept external output buffers but do not reject out-of-range writes (small buf or large offset). This allows silent partial writes into caller-provided buffers. This vulnerability is fixed in 14.0.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-uuid | no fix listed | DEBIAN-CVE-2026-41907 |
| Debian:13 | node-uuid | no fix listed | DEBIAN-CVE-2026-41907 |
| Debian:14 | node-uuid | 14.0.0+~11.0.0-1 | DEBIAN-CVE-2026-41907 |
| Ubuntu:22.04:LTS | node-uuid | no fix listed | UBUNTU-CVE-2026-41907 |
| Ubuntu:24.04:LTS | node-uuid | no fix listed | UBUNTU-CVE-2026-41907 |
| Ubuntu:25.10 | node-uuid | no fix listed | UBUNTU-CVE-2026-41907 |
| Ubuntu:26.04:LTS | node-uuid | no fix listed | UBUNTU-CVE-2026-41907 |
| Ubuntu:26.10 | node-uuid | no fix listed | UBUNTU-CVE-2026-41907 |
| npm | uuid | 13.0.1 | GHSA-w5hq-g745-h8pq |
| npm | uuid | 12.0.1 | GHSA-w5hq-g745-h8pq |
| npm | uuid | 11.1.1 | GHSA-w5hq-g745-h8pq |
Affected products (as reported)
Weakness: CWE-823, CWE-787 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
References
- https://github.com/uuidjs/uuid/security/advisories/GHSA-w5hq-g745-h8pq x_refsource_CONFIRM