Vulnerability · Published May 9, 2026 · Assigned by vmware
CVE-2026-41705
High 8.6
In plain English
A high-severity expression language injection in Spring AI from Spring. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs. Spring AI 1.0.x: affected from 1.0.0 through latest 1.0.x; upgrade to 1.0.7 or greater. Spring AI 1.1.x: affected from 1.1.0 through latest 1.1.x; upgrade to 1.1.6 or greater.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.springframework.ai:spring-ai-milvus-store | 1.0.7 | GHSA-v632-2m87-7469 |
| Maven | org.springframework.ai:spring-ai-milvus-store | 1.1.6 | GHSA-v632-2m87-7469 |
| Maven | org.springframework.ai:spring-ai-typesense-store | 1.0.7 | GHSA-v632-2m87-7469 |
| Maven | org.springframework.ai:spring-ai-typesense-store | 1.1.6 | GHSA-v632-2m87-7469 |
Affected products (as reported)
Weakness: CWE-917 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L