Vulnerability · Published Apr 24, 2026 · Assigned by GitHub_M
CVE-2026-41677rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length
Low 1.7
In plain English
A low-severity out-of-bounds read in rust-openssl from rust-openssl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rust-openssl | no fix listed | DEBIAN-CVE-2026-41677 |
| Debian:13 | rust-openssl | no fix listed | DEBIAN-CVE-2026-41677 |
| Debian:14 | rust-openssl | 0.10.78-1 | DEBIAN-CVE-2026-41677 |
| Ubuntu:25.10 | rust-openssl | no fix listed | UBUNTU-CVE-2026-41677 |
| Ubuntu:26.04:LTS | rust-openssl | no fix listed | UBUNTU-CVE-2026-41677 |
| Ubuntu:26.10 | rust-openssl | no fix listed | UBUNTU-CVE-2026-41677 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rust-openssl | rust-openssl | >= 0.9.0, < 0.10.78 |
Weakness: CWE-125, CWE-1284 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N/E:U