Vulnerability · Published Apr 24, 2026 · Assigned by GitHub_M
CVE-2026-41676rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1
High 7.2
In plain English
A high-severity out-of-bounds write in rust-openssl from rust-openssl. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.27 to before 0.10.78, Deriver::derive (and PkeyCtxRef::derive) sets len = buf.len() and passes it as the in/out length to EVP_PKEY_derive, relying on OpenSSL to honor it. On OpenSSL 1.1.x, X25519, X448, DH and HKDF-extract ignore the incoming *keylen, unconditionally writing the full shared secret (32/56/prime-size bytes). A caller passing a short slice gets a heap/stack overflow from safe code. OpenSSL 3.x providers do check, so this only impacts older OpenSSL. This vulnerability is fixed in 0.10.78.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | rust-openssl | no fix listed | DEBIAN-CVE-2026-41676 |
| Debian:13 | rust-openssl | no fix listed | DEBIAN-CVE-2026-41676 |
| Debian:14 | rust-openssl | 0.10.78-1 | DEBIAN-CVE-2026-41676 |
| Ubuntu:25.10 | rust-openssl | no fix listed | UBUNTU-CVE-2026-41676 |
| Ubuntu:26.04:LTS | rust-openssl | no fix listed | UBUNTU-CVE-2026-41676 |
| Ubuntu:26.10 | rust-openssl | no fix listed | UBUNTU-CVE-2026-41676 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| rust-openssl | rust-openssl | >= 0.9.27, < 0.10.78 |
Weakness: CWE-787, CWE-131 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U