Vulnerability · Published May 7, 2026 · Assigned by GitHub_M

CVE-2026-41673xmldom: Denial of service via uncontrolled recursion in XML serialization

High 7.5

In plain English

A high-severity security flaw in xmldom from xmldom. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 51% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 49.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

xmldom is a pure JavaScript W3C standard-based (XML DOM Level 2 Core) `DOMParser` and `XMLSerializer` module. In @xmldom/xmldom prior to versions 0.9.10 and 0.8.13 and xmldom version 0.6.0 and prior, seven recursive traversals in lib/dom.js operate without a depth limit. A sufficiently deeply nested DOM tree causes a RangeError: Maximum call stack size exceeded, crashing the application. This issue has been patched in versions @xmldom/xmldom versions 0.9.10 and 0.8.13.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-xmldomno fix listedDEBIAN-CVE-2026-41673
Debian:13node-xmldomno fix listedDEBIAN-CVE-2026-41673
Debian:14node-xmldom0.9.10-1DEBIAN-CVE-2026-41673
Ubuntu:22.04:LTSnode-xmldomno fix listedUBUNTU-CVE-2026-41673
Ubuntu:24.04:LTSnode-xmldomno fix listedUBUNTU-CVE-2026-41673
Ubuntu:25.10node-xmldomno fix listedUBUNTU-CVE-2026-41673
Ubuntu:26.04:LTSnode-xmldomno fix listedUBUNTU-CVE-2026-41673
Ubuntu:26.10node-xmldomno fix listedUBUNTU-CVE-2026-41673
npm@xmldom/xmldom0.9.10GHSA-2v35-w6hq-6mfw
npm@xmldom/xmldom0.8.13GHSA-2v35-w6hq-6mfw
npmxmldomno fix listedGHSA-2v35-w6hq-6mfw

Affected products (as reported)

VendorProductVersions
xmldom xmldom xmldom <= 0.6.0@xmldom/xmldom >= 0.9.0, < 0.9.10@xmldom/xmldom < 0.8.13

Weakness: CWE-674, CWE-776 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References