Vulnerability · Published Jul 27, 2026 · Assigned by apache

CVE-2026-41608Apache Thrift: Unbounded Zlib Decompression in Python THeaderTransport

High 7.5

In plain English

A high-severity security flaw in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)1.0%top 36.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Python bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12thriftno fix listedDEBIAN-CVE-2026-41608
Debian:13thriftno fix listedDEBIAN-CVE-2026-41608
Debian:14thrift0.24.0-2DEBIAN-CVE-2026-41608
PyPIthrift0.24.0GHSA-6pjx-3pjc-mrj8
PyPIthrift0.24.0PYSEC-2026-3925
Ubuntu:22.04:LTSthriftno fix listedUBUNTU-CVE-2026-41608
Ubuntu:24.04:LTSthriftno fix listedUBUNTU-CVE-2026-41608
Ubuntu:26.04:LTSthriftno fix listedUBUNTU-CVE-2026-41608
Ubuntu:26.10thriftno fix listedUBUNTU-CVE-2026-41608

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Thrift 0 – before 0.24.0

Weakness: CWE-409 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References