Vulnerability · Published Sep 15, 2026 · Assigned by GitHub_M

CVE-2026-41573OpenAM LDAP Injection via `_queryId` Parameter

High 7.1

In plain English

A high-severity security flaw in OpenAM from OpenIdentityPlatform. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.5%top 57.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, IdentityResourceV1.queryCollection() passes the _queryId parameter from /json/{realm}/users to CrestQuery with escapeQueryId disabled, bypassing protection added for CVE-2021-29156. The unescaped value reaches DJLDAPv3Repo.getFilter(), where it is concatenated into an LDAP filter, allowing an authenticated attacker to inject LDAP metacharacters for user enumeration and blind LDAP injection. This issue is fixed in version 16.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.openidentityplatform.openam:openam-core-rest16.1.1GHSA-2vg8-q4c2-5cw3

Affected products (as reported)

VendorProductVersions
OpenIdentityPlatform OpenAM < 16.1.1

Weakness: CWE-90 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

References