Vulnerability · Published May 8, 2026 · Assigned by GitHub_M
CVE-2026-41501electerm has Command Injection Vulnerability via runLinux function
Critical 9.8
In plain English
A critical-severity command injection in electerm from electerm. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
electerm is an open-sourced terminal/ssh/sftp/telnet/serialport/RDP/VNC/Spice/ftp client. Prior to version 3.3.8, a command injection vulnerability exists in github.com/elcterm/electerm/npm/install.js:130. The runLinux() function appends attacker-controlled remote version strings directly into an exec("rm -rf ...") command without validation. This issue has been patched in version 3.3.8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | electerm | 3.3.8 | GHSA-8x35-hph8-37hq |
Affected products (as reported)
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/electerm/electerm/security/advisories/GHSA-8x35-hph8-37hq x_refsource_CONFIRM
- https://github.com/electerm/electerm/commit/59708b38c8a52f5db59d7d4eff98e31d573128ee x_refsource_MISC
- https://github.com/electerm/electerm/releases/tag/v3.3.8 x_refsource_MISC