Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M
CVE-2026-41273Flowise: Unauthenticated OAuth 2.0 Access Token Disclosure via Public Chatflow
High 7.7
In plain English
A high-severity missing authentication in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise contains an authentication bypass vulnerability that allows an unauthenticated attacker to obtain OAuth 2.0 access tokens associated with a public chatflow. By accessing a public chatflow configuration endpoint, an attacker can retrieve internal workflow data, including OAuth credential identifiers, which can then be used to refresh and obtain valid OAuth 2.0 access tokens without authentication. This vulnerability is fixed in 3.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.0 | GHSA-6f7g-v4pp-r667 |
Affected products (as reported)
Weakness: CWE-306 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:H/SI:N/SA:N
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-6f7g-v4pp-r667 x_refsource_CONFIRM