Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M
CVE-2026-41272Flowise: SSRF Protection Bypass (TOCTOU & Default Insecure)
High 7.1
In plain English
A high-severity server-side request forgery in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the core security wrappers (secureAxiosRequest and secureFetch) intended to prevent Server-Side Request Forgery (SSRF) contain multiple logic flaws. These flaws allow attackers to bypass the allow/deny lists via DNS Rebinding (Time-of-Check Time-of-Use) or by exploiting the default configuration which fails to enforce any deny list. This vulnerability is fixed in 3.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.0 | GHSA-2x8m-83vc-6wv4 |
| npm | flowise-components | 3.1.0 | GHSA-2x8m-83vc-6wv4 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| FlowiseAI | Flowise | < 3.1.0 |
| FlowiseAI | flowise-components | < 3.1.0 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-2x8m-83vc-6wv4 x_refsource_CONFIRM