Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M
CVE-2026-41271Flowise: APIChain Prompt Injection SSRF in GET/POST API Chains
High 7.1
In plain English
A high-severity server-side request forgery in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, a Server-Side Request Forgery (SSRF) vulnerability exists in FlowiseAI's POST/GET API Chain components that allows unauthenticated attackers to force the server to make arbitrary HTTP requests to internal and external systems. By injecting malicious prompt templates, attackers can bypass the intended API documentation constraints and redirect requests to sensitive internal services, potentially leading to internal network reconnaissance and data exfiltration. This vulnerability is fixed in 3.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.0 | GHSA-6r77-hqx7-7vw8 |
| npm | flowise-components | 3.1.0 | GHSA-6r77-hqx7-7vw8 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| FlowiseAI | Flowise | < 3.1.0 |
| FlowiseAI | flowise-components | < 3.1.0 |
Weakness: CWE-918 · Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-6r77-hqx7-7vw8 x_refsource_CONFIRM