Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M
CVE-2026-41266Flowise: Sensitive Data Leak in public-chatbotConfig
High 7.7
In plain English
A high-severity information exposure in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 4.1% (higher than 91% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, /api/v1/public-chatbotConfig/:id ep exposes sensitive data including API keys, HTTP authorization headers and internal configuration without any authentication. An attacker with knowledge just of a chatflow UUID can retrieve credentials stored in password type fields and HTTP headers, leading to credential theft and more. This vulnerability is fixed in 3.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.0 | GHSA-4jpm-cgx2-8h37 |
Affected products (as reported)
Weakness: CWE-200, CWE-522, CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-4jpm-cgx2-8h37 x_refsource_CONFIRM