Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M
CVE-2026-41265Flowise: Airtable_Agent Code Injection Remote Code Execution Vulnerability
Critical 9.2
In plain English
A critical-severity command injection in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 47% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the specific flaw exists within the run method of the Airtable_Agents class. The issue results from the lack of proper sandboxing when evaluating an LLM generated python script. Using prompt injection techniques, an unauthenticated attacker with the ability to send prompts to a chatflow using the Airtable Agent node may convince an LLM to respond with a malicious python script that executes attacker controlled commands on the flowise server. This vulnerability is fixed in 3.1.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | flowise | 3.1.0 | GHSA-v38x-c887-992f |
| npm | flowise-components | 3.1.0 | GHSA-v38x-c887-992f |
Affected products (as reported)
Weakness: CWE-77 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-v38x-c887-992f x_refsource_CONFIRM