Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M

CVE-2026-41264Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability

Critical 9.2

In plain English

A critical-severity security flaw in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.8% (higher than 78% of all known vulnerabilities). Ready-made attack tooling exists: Metasploit. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.2Critical
Exploit odds (30 days)1.8%top 21.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Metasploit

Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, the specific flaw exists within the run method of the CSV_Agents class. The issue results from the lack of proper sandboxing when evaluating an LLM generated python script. An attacker can leverage this vulnerability to execute code in the context of the user running the server. Using prompt injection techniques, an unauthenticated attacker with the ability to send prompts to a chatflow using the CSV Agent node may convince an LLM to respond with a malicious python script that executes attacker controlled commands on the Flowise server. This vulnerability is fixed in 3.1.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmflowise3.1.0GHSA-3hjv-c53m-58jj
npmflowise-components3.1.0GHSA-3hjv-c53m-58jj

Affected products (as reported)

VendorProductVersions
FlowiseAI Flowise < 3.1.0

Weakness: CWE-184 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References