Vulnerability · Published May 9, 2026 · Assigned by GitHub_M

CVE-2026-41163bubblewrap vulnerable to privilege escalation in setuid mode via ptrace

High 7.0

In plain English

A high-severity privilege mismanagement in bubblewrap from containers. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.0High
Exploit odds (30 days)0.3%top 80.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

bubblewrap is a low-level unprivileged sandboxing tool. From version 0.11.0 to before version 0.11.2, if bubblewrap is installed in setuid mode then the user can use ptrace to attach to bubblewrap and control the unprivileged part of the sandbox setup phase. This allows the attacker to arbitrarily use the privileged operations, and in particular the "overlay mount" operation, allowing the creation of overlay mounts which is otherwise not allowed in the setuid version of bubblewrap. This issue has been patched in version 0.11.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24bubblewrap0ALPINE-CVE-2026-41163
Debian:13bubblewrap0.11.0-2+deb13u1DEBIAN-CVE-2026-41163
Debian:14bubblewrap0.11.2-1DEBIAN-CVE-2026-41163
Ubuntu:25.10bubblewrap0.11.0-2ubuntu0.1UBUNTU-CVE-2026-41163
Ubuntu:26.04:LTSbubblewrap0.11.1-1ubuntu0.1UBUNTU-CVE-2026-41163

Affected products (as reported)

VendorProductVersions
containers bubblewrap >= 0.11.0, < 0.11.2

Weakness: CWE-269 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References