Vulnerability · Published Apr 23, 2026 · Assigned by GitHub_M

CVE-2026-41137Flowise: Code Injection in CSVAgent leads to Authenticated RCE

Critical 9.4

In plain English

A critical-severity code injection in Flowise from FlowiseAI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 73% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.4Critical
Exploit odds (30 days)1.5%top 26.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, The CSVAgent allows providing a custom Pandas CSV read code. Due to lack of sanitization, an attacker can provide a command injection payload that will get interpolated and executed by the server. This vulnerability is fixed in 3.1.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmflowise3.1.0GHSA-9wc7-mj3f-74xv
npmflowise-components3.1.0GHSA-9wc7-mj3f-74xv

Affected products (as reported)

VendorProductVersions
FlowiseAI Flowise < 3.1.0
FlowiseAI flowise-components < 3.1.0

Weakness: CWE-94 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

References