Vulnerability · Published Apr 21, 2026 · Assigned by GitHub_M
CVE-2026-40944Oxia: TLS CA certificate chain validation fails with multi-certificate PEM bundles
Medium 6.9
In plain English
A medium-severity improper certificate validation in oxia from oxia-db. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Oxia is a metadata store and coordination system. Prior to 0.16.2, the trustedCertPool() function in the TLS configuration only parses the first PEM block from CA certificate files. When a CA bundle contains multiple certificates (e.g., intermediate + root CA), only the first certificate is loaded. This silently breaks certificate chain validation for mTLS. This vulnerability is fixed in 0.16.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/oxia-db/oxia | 0.16.2 | GHSA-7jrq-q4pq-rhm6 |
| Go | github.com/oxia-db/oxia | 0.16.2 | GO-2026-5226 |
Affected products (as reported)
Weakness: CWE-295 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
References
- https://github.com/oxia-db/oxia/security/advisories/GHSA-7jrq-q4pq-rhm6 x_refsource_CONFIRM