Vulnerability · Published May 12, 2026 · Assigned by GitHub_M

CVE-2026-40863PhpSpreadsheet: CPU Denial of Service via Unbounded Row Index in SpreadsheetML XML Reader

High 7.5

In plain English

A high-severity resource allocation without limits in PhpSpreadsheet from PHPOffice. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 66.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0, the SpreadsheetML XML reader (Reader\Xml) does not validate the ss:Index row attribute against the maximum allowed row count (AddressRange::MAX_ROW = 1,048,576). An attacker can craft a SpreadsheetML XML file with ss:Index="999999999" on a <Row> element, which inflates the internal cachedHighestRow to ~1 billion. Any subsequent call to getRowIterator() without an explicit end row will attempt to iterate ~1 billion rows, causing CPU exhaustion and denial of service. This vulnerability is fixed in 1.30.4, 2.1.16, 2.4.5, 3.10.5, and 5.7.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistphpoffice/phpspreadsheet5.7.0GHSA-84wq-86v6-x5j6
Packagistphpoffice/phpspreadsheet3.10.5GHSA-84wq-86v6-x5j6
Packagistphpoffice/phpspreadsheet2.4.5GHSA-84wq-86v6-x5j6
Packagistphpoffice/phpspreadsheet2.1.16GHSA-84wq-86v6-x5j6
Packagistphpoffice/phpspreadsheet1.30.6GHSA-84wq-86v6-x5j6

Affected products (as reported)

VendorProductVersions
PHPOffice PhpSpreadsheet < 1.30.4>= 2.0.0, < 2.1.16>= 2.2.0, < 2.4.5>= 3.3.0, < 3.10.5>= 4.0.0, < 5.7.0

Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References