Vulnerability · Published Apr 27, 2026 · Assigned by apache

CVE-2026-40453Apache Camel JMS, Apache Camel CoAP, Apache Camel Google PubSub: Incomplete fix for CVE-2025-27636 in non-HTTP HeaderFilterStrategies (camel-jms, camel-sjms, camel-coap, camel-google-pubsub) allows case-variant header injection

Critical 9.9

In plain English

A critical-severity security flaw in Apache Camel CoAP from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.1% (higher than 82% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.9Critical
Exploit odds (30 days)2.1%top 18.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

The fix for CVE-2025-27636 added setLowerCase(true) to HttpHeaderFilterStrategy so that case-variant header names such as 'CAmelExecCommandExecutable' are filtered out alongside 'CamelExecCommandExecutable'. The same setLowerCase(true) call was not applied to five non-HTTP HeaderFilterStrategy implementations: JmsHeaderFilterStrategy and ClassicJmsHeaderFilterStrategy in camel-jms, SjmsHeaderFilterStrategy in camel-sjms, CoAPHeaderFilterStrategy in camel-coap, and GooglePubsubHeaderFilterStrategy in camel-google-pubsub. Because those strategies use case-sensitive String.startsWith('Camel'/'camel') filtering while the Camel Exchange stores headers in a case-insensitive map, an attacker with JMS (or equivalent) producer access to the broker consumed by a Camel route can inject case-variant Camel internal headers, which are then resolved by downstream components such as camel-exec and camel-file using their canonical casing. This enables remote code execution and arbitrary file write on routes that forward JMS messages to header-driven components. This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.2, from 4.19.0 before 4.20.0. Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.camel:camel-coap4.14.6GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-coap4.18.2GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-coap4.20.0GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-google-pubsub4.14.6GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-google-pubsub4.18.2GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-google-pubsub4.20.0GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-jms4.14.6GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-jms4.18.2GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-jms4.20.0GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-sjms4.14.6GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-sjms4.18.2GHSA-jg2m-9x48-3gvj
Mavenorg.apache.camel:camel-sjms4.20.0GHSA-jg2m-9x48-3gvj

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Camel JMS 3.0.0 – before 4.14.64.15.0 – before 4.18.24.19.0 – before 4.20.0
Apache Software Foundation Apache Camel CoAP 3.0.0 – before 4.14.64.15.0 – before 4.18.24.19.0 – before 4.20.0
Apache Software Foundation Apache Camel Google PubSub 3.0.0 – before 4.14.64.15.0 – before 4.18.24.19.0 – before 4.20.0

Weakness: CWE-178 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References