Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M
CVE-2026-40347Python-Multipart affected by Denial of Service via large multipart preamble or epilogue data
Medium 5.3
In plain English
A medium-severity uncontrolled resource consumption in python-multipart from Kludex. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Python-Multipart is a streaming multipart parser for Python. Versions prior to 0.0.26 have a denial of service vulnerability when parsing crafted `multipart/form-data` requests with large preamble or epilogue sections. Upgrade to version 0.0.26 or later, which skips ahead to the next boundary candidate when processing leading CR/LF data and immediately discards epilogue data after the closing boundary.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | python-multipart | no fix listed | DEBIAN-CVE-2026-40347 |
| Debian:13 | python-multipart | no fix listed | DEBIAN-CVE-2026-40347 |
| Debian:14 | python-multipart | 0.0.26-1 | DEBIAN-CVE-2026-40347 |
| PyPI | python-multipart | 0.0.26 | GHSA-mj87-hwqh-73pj |
| PyPI | python-multipart | 0.0.26 | PYSEC-2026-3038 |
| Ubuntu:25.10 | python-multipart | no fix listed | UBUNTU-CVE-2026-40347 |
| Ubuntu:26.04:LTS | python-multipart | no fix listed | UBUNTU-CVE-2026-40347 |
| Ubuntu:26.10 | python-multipart | no fix listed | UBUNTU-CVE-2026-40347 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Kludex | python-multipart | < 0.0.26 |
Weakness: CWE-400, CWE-834 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
References
- https://github.com/Kludex/python-multipart/security/advisories/GHSA-mj87-hwqh-73pj x_refsource_CONFIRM
- https://github.com/Kludex/python-multipart/releases/tag/0.0.26 x_refsource_MISC