Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M

CVE-2026-40342Firebird: Path Traversal + Arbitrary File Write Leads to Remote Code Execution

Critical 10.0

In plain English

A critical-severity path traversal in firebird from FirebirdSQL. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)10.0Critical
Exploit odds (30 days)0.7%top 46.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, the external engine plugin loader concatenates a user-supplied engine name into a filesystem path without filtering path separators or .. components. An authenticated user with CREATE FUNCTION privileges can use a crafted ENGINE name to load an arbitrary shared library from anywhere on the filesystem via path traversal. The library's initialization code executes immediately during loading, before Firebird validates the module, achieving code execution as the server's OS account. This issue has been fixed in versions 5.0.4, 4.0.7 and 3.0.14.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12firebird3.0no fix listedDEBIAN-CVE-2026-40342
Debian:13firebird3.0no fix listedDEBIAN-CVE-2026-40342
Debian:14firebird3.03.0.14.ds7-1DEBIAN-CVE-2026-40342
Debian:13firebird4.0no fix listedDEBIAN-CVE-2026-40342
Debian:14firebird4.04.0.7.3271.ds6-1DEBIAN-CVE-2026-40342
Ubuntu:22.04:LTSfirebird3.0no fix listedUBUNTU-CVE-2026-40342
Ubuntu:24.04:LTSfirebird3.0no fix listedUBUNTU-CVE-2026-40342
Ubuntu:25.10firebird3.0no fix listedUBUNTU-CVE-2026-40342
Ubuntu:26.04:LTSfirebird3.0no fix listedUBUNTU-CVE-2026-40342
Ubuntu:26.10firebird3.0no fix listedUBUNTU-CVE-2026-40342
Ubuntu:25.10firebird4.0no fix listedUBUNTU-CVE-2026-40342
Ubuntu:26.04:LTSfirebird4.0no fix listedUBUNTU-CVE-2026-40342
Ubuntu:26.10firebird4.0no fix listedUBUNTU-CVE-2026-40342

Affected products (as reported)

VendorProductVersions
FirebirdSQL firebird < 3.0.14>= 4.0.0, < 4.0.7>= 5.0.0, < 5.0.4

Weakness: CWE-22, CWE-427, CWE-73, CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

References