Vulnerability · Published May 6, 2026 · Assigned by GitHub_M
CVE-2026-40296PhpSpreadsheet vulnerable to XSS in HTML writer via custom number format codes
Medium 5.4
In plain English
A medium-severity cross-site scripting in PhpSpreadsheet from PHPOffice. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. The HTML writer skips htmlspecialchars escaping when a cell's formatted value differs from the original value. When a cell has a custom number format containing the text placeholder @ along with any additional literal characters (for example ". @", "@ ", or "x@"), the formatter replaces @ with the cell value and adds the extra characters, causing the formatted value to differ from the original and bypassing HTML escaping entirely. An attacker who can control the cell value and number format of an uploaded spreadsheet that is later converted to HTML and displayed to other users can achieve stored cross-site scripting. This issue is fixed in versions 5.7.0, 3.10.5, 2.4.5, 2.1.16, and 1.30.4.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | phpoffice/phpspreadsheet | 5.7.0 | GHSA-hrmw-qprp-wgmc |
| Packagist | phpoffice/phpspreadsheet | 3.10.5 | GHSA-hrmw-qprp-wgmc |
| Packagist | phpoffice/phpspreadsheet | 2.4.5 | GHSA-hrmw-qprp-wgmc |
| Packagist | phpoffice/phpspreadsheet | 2.1.16 | GHSA-hrmw-qprp-wgmc |
| Packagist | phpoffice/phpspreadsheet | 1.30.4 | GHSA-hrmw-qprp-wgmc |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| PHPOffice | PhpSpreadsheet | >= 4.0.0, <= 5.6.0>= 3.3.0, <= 3.10.4>= 2.2.0, <= 2.4.4>= 2.0.0, <= 2.1.15<= 1.30.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N