Vulnerability · Published Apr 15, 2026 · Assigned by GitHub_M

CVE-2026-40261Composer has Command Injection via Malicious Perforce Reference

High 8.8

In plain English

A high-severity OS command injection in composer from composer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 77% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)1.7%top 22.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::syncCodeBase() method, which appends the $sourceReference parameter to a shell command without proper escaping, and additionally in the Perforce::generateP4Command() method as in GHSA-wg36-wvj6-r67p / CVE-2026-40176, which interpolates user-supplied Perforce connection parameters (port, user, client) from the source url field without proper escaping. An attacker can inject arbitrary commands through crafted source reference or source url values containing shell metacharacters, even if Perforce is not installed. Unlike CVE-2026-40176, the source reference and url are provided as part of package metadata, meaning any compromised or malicious Composer repository can serve package metadata declaring perforce as a source type with malicious values. This vulnerability is exploitable when installing or updating dependencies from source, including the default behavior when installing dev-prefixed versions. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline). If developers are unable to immediately update, they can avoid installing dependencies from source by using --prefer-dist or the preferred-install: dist config setting, and only use trusted Composer repositories as a workaround.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.23composer2.9.6-r0ALPINE-CVE-2026-40261
Alpine:v3.24composer2.9.6-r0ALPINE-CVE-2026-40261
Debian:12composer2.5.5-1+deb12u4DEBIAN-CVE-2026-40261
Debian:13composer2.8.8-1+deb13u2DEBIAN-CVE-2026-40261
Debian:14composer2.9.7-1DEBIAN-CVE-2026-40261
Packagistcomposer/composer2.2.27GHSA-gqw4-4w2p-838q
Packagistcomposer/composer2.9.6GHSA-gqw4-4w2p-838q
Ubuntu:25.10composerno fix listedUBUNTU-CVE-2026-40261
Ubuntu:26.04:LTScomposerno fix listedUBUNTU-CVE-2026-40261
Ubuntu:26.10composerno fix listedUBUNTU-CVE-2026-40261

Affected products (as reported)

VendorProductVersions
composer composer >= 2.3.0, < 2.9.6>= 1.0.0, < 2.2.27

Weakness: CWE-78, CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References