Vulnerability · Published Apr 15, 2026 · Assigned by GitHub_M
CVE-2026-40176Composer is vulnerable to Command Injection via Malicious Perforce Repository
High 7.8
In plain English
A high-severity improper input validation in composer from composer. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shell commands by interpolating user-supplied Perforce connection parameters (port, user, client) without proper escaping. An attacker can inject arbitrary commands through these values in a malicious composer.json declaring a Perforce VCS repository, leading to command execution in the context of the user running Composer, even if Perforce is not installed. VCS repositories are only loaded from the root composer.json or the composer config directory, so this cannot be exploited through composer.json files of packages installed as dependencies. Users are at risk if they run Composer commands on untrusted projects with attacker-supplied composer.json files. This issue has been fixed in Composer 2.2.27 (2.2 LTS) and 2.9.6 (mainline).
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | composer | 2.9.6-r0 | ALPINE-CVE-2026-40176 |
| Alpine:v3.24 | composer | 2.9.6-r0 | ALPINE-CVE-2026-40176 |
| Debian:12 | composer | 2.5.5-1+deb12u4 | DEBIAN-CVE-2026-40176 |
| Debian:13 | composer | 2.8.8-1+deb13u2 | DEBIAN-CVE-2026-40176 |
| Debian:14 | composer | 2.9.7-1 | DEBIAN-CVE-2026-40176 |
| Packagist | composer/composer | 2.2.27 | GHSA-wg36-wvj6-r67p |
| Packagist | composer/composer | 2.9.6 | GHSA-wg36-wvj6-r67p |
| Ubuntu:25.10 | composer | no fix listed | UBUNTU-CVE-2026-40176 |
| Ubuntu:26.04:LTS | composer | no fix listed | UBUNTU-CVE-2026-40176 |
| Ubuntu:26.10 | composer | no fix listed | UBUNTU-CVE-2026-40176 |
Affected products (as reported)
Weakness: CWE-20, CWE-78 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/composer/composer/security/advisories/GHSA-wg36-wvj6-r67p x_refsource_CONFIRM
- https://access.redhat.com/errata/RHSA-2026:8165 x_refsource_MISC
- https://access.redhat.com/security/cve/CVE-2026-40176 x_refsource_MISC
- https://bugzilla.redhat.com/show_bug.cgi?id=2458828 x_refsource_MISC
- https://github.com/FriendsOfPHP/security-advisories/blob/master/composer/composer/CVE-2026-40176.yaml x_refsource_MISC
- https://github.com/composer/composer/releases/tag/2.2.27 x_refsource_MISC
- https://github.com/composer/composer/releases/tag/2.9.6 x_refsource_MISC
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40176.json x_refsource_MISC