Vulnerability · Published Apr 17, 2026 · Assigned by GitHub_M
CVE-2026-40155Auth0 Next.js SDK has Improper Proxy Cache Lookup
Medium 5.4
In plain English
A medium-severity incorrect authorization in nextjs-auth0 from auth0. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @auth0/nextjs-auth0 | 4.18.0 | GHSA-xq8m-7c5p-c2r6 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| auth0 | nextjs-auth0 | >= 4.12.0, < 4.18.0 |
Weakness: CWE-863, CWE-362 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N