Vulnerability · Published May 5, 2026 · Assigned by GitHub_M

CVE-2026-40110jupyter-server CORS origin validation bypass via unanchored regex in allow_origin_pat

High 7.1

In plain English

A high-severity security flaw in jupyter_server from jupyter-server. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.1High
Exploit odds (30 days)0.3%top 75.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Jupyter Server is the backend for Jupyter web applications. In versions 2.17.0 and earlier, the Origin header validation uses Python's re.match() to check incoming origins against the allow_origin_pat configuration value. Because re.match() only anchors at the start of the string and does not require a full match, a pattern intended to match only a trusted domain (e.g., trusted.example.com) will also match any origin that begins with that domain followed by additional characters (e.g., trusted.example.com.evil.com). An attacker who controls such a domain can bypass the CORS origin restriction and make cross-origin requests to the Jupyter Server API from an untrusted site. This issue has been fixed in version 2.18.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.24jupyter-server2.18.2-r0ALPINE-CVE-2026-40110
Debian:12jupyter-serverno fix listedDEBIAN-CVE-2026-40110
Debian:13jupyter-serverno fix listedDEBIAN-CVE-2026-40110
Debian:14jupyter-server2.20.0-1DEBIAN-CVE-2026-40110
PyPIjupyter-server2.18.0PYSEC-2026-2187
PyPIjupyter-server2.18.0GHSA-24qx-w28j-9m6p
Ubuntu:22.04:LTSjupyter-serverno fix listedUBUNTU-CVE-2026-40110
Ubuntu:24.04:LTSjupyter-serverno fix listedUBUNTU-CVE-2026-40110
Ubuntu:25.10jupyter-serverno fix listedUBUNTU-CVE-2026-40110
Ubuntu:26.04:LTSjupyter-serverno fix listedUBUNTU-CVE-2026-40110
Ubuntu:26.10jupyter-serverno fix listedUBUNTU-CVE-2026-40110

Affected products (as reported)

VendorProductVersions
jupyter-server jupyter_server <= 2.17.0

Weakness: CWE-777, CWE-625 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N

References