Vulnerability · Published Apr 8, 2026 · Assigned by GitHub_M

CVE-2026-39864Kamailio Auth: Processing Vulnerability For Additional Authenticated User Identity Checks

Medium 4.4

In plain English

A medium-severity out-of-bounds read in kamailio from kamailio. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.4Medium
Exploit odds (30 days)0.3%top 75.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kamailio is an open source implementation of a SIP Signaling Server. Prior to 6.0.5 and 5.8.7, an out-of-bounds read in the auth module of Kamailio (formerly OpenSER and SER) allows remote attackers to cause a denial of service (process crash) via a specially crafted SIP packet if a successful user authentication without a database backend is followed by additional user identity checks. This vulnerability is fixed in 6.0.5 and 5.8.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12kamailiono fix listedDEBIAN-CVE-2026-39864
Debian:13kamailio6.0.1-1+deb13u2DEBIAN-CVE-2026-39864
Debian:14kamailio6.0.5-1DEBIAN-CVE-2026-39864
Ubuntu:22.04:LTSkamailiono fix listedUBUNTU-CVE-2026-39864
Ubuntu:24.04:LTSkamailiono fix listedUBUNTU-CVE-2026-39864
Ubuntu:25.10kamailiono fix listedUBUNTU-CVE-2026-39864

Affected products (as reported)

VendorProductVersions
kamailio kamailio < 5.8.7>= 6.0.0, < 6.0.5

Weakness: CWE-125 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H

References