Vulnerability · Published Mar 6, 2026 · Assigned by VulDB
CVE-2026-3610HSC Cybersecurity Mailinspector URL mliUserValidation.php cross site scripting
Medium 4.3
In plain English
A medium-severity cross-site scripting in Mailinspector from HSC Cybersecurity. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities).
Official description
A vulnerability was found in HSC Cybersecurity Mailinspector up to 5.3.2-3. Affected by this issue is some unknown functionality of the file /mailinspector/mliUserValidation.php of the component URL Handler. The manipulation of the argument error_description results in cross site scripting. The attack may be performed from remote. The exploit has been made public and could be used. Upgrading to version 5.4.0 can resolve this issue. You should upgrade the affected component. The vendor was contacted early and responded very professional: "We have already implemented the fix and made a hotfix available to affected customers, ensuring mitigation while the official release 5.4.0 has not yet been published. This allows customers to address the issue immediately, outside the regular release cycle."
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| HSC Cybersecurity | Mailinspector | 5.3.2-3 |
Weakness: CWE-79, CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N/E:P/RL:O/RC:C
References
- VDB-349219 | HSC Cybersecurity Mailinspector URL mliUserValidation.php cross site scripting vdb-entry, technical-description
- VDB-349219 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- Submit #748710 | HSC Cybersecurity mailinspector 5.3.2-3 Cross Site Scripting third-party-advisory
- https://docs.google.com/document/d/1KI2SIDcVm5U3Yzo5tNT5YOwREQWe_5BJaWe-ctRmLoI/edit?usp=sharing broken-link, exploit