Vulnerability · Published Apr 9, 2026 · Assigned by GitHub_M

CVE-2026-35207deepinid plugin in dde-control-center is configured to skip TLS certificate verification when downloading avatar from remote server

Medium 5.4

In plain English

A medium-severity improper certificate validation in dde-control-center from linuxdeepin. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 5% of all known vulnerabilities).

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.2%top 95.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

dde-control-center is the control panel of DDE, the Deepin Desktop Environment. plugin-deepinid is a plugin in dde-control-center, which provides the deepinid cloud service. Prior to 6.1.80, plugin-deepinid is configured to skip TLS certificate verification when fetching the user's avatar from openapi.deepin.com or other providers. An MITM attacker could intercept the traffic, replace the avatar with a malicious or misleading image, and potentially identify the user by the avatar. This vulnerability is fixed in dde-control-center 6.1.80 and 5.9.9.

Affected products (as reported)

VendorProductVersions
linuxdeepin dde-control-center >= 6.1.35, < 6.1.80>= 5.5.3, < 5.9.9
linuxdeepin deepin-deepinid-plugin >= 2.0.1, <= 2.0.9

Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

References