Vulnerability · Published Mar 4, 2026 · Assigned by openjs

CVE-2026-3520Multer vulnerable to Denial of Service via uncontrolled recursion

High 7.5

In plain English

A high-severity resource allocation without limits in multer from expressjs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 57% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.8%top 42.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability in Multer prior to version 2.1.1 allows an attacker to trigger a Denial of Service (DoS) by sending malformed requests, potentially causing stack overflow. Users should upgrade to version 2.1.1 to receive a patch. No known workarounds are available.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmmulter2.1.1GHSA-5528-5vmv-3xc2

Affected products (as reported)

VendorProductVersions
expressjs multer 0 – before 2.1.1

Weakness: CWE-674, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References