Vulnerability · Published Apr 6, 2026 · Assigned by GitHub_M
CVE-2026-35175Ajenti has an authorization bypass during custom package installation
High 7.2
In plain English
A high-severity missing authorization in ajenti from ajenti. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)7.2High
Exploit odds (30 days)0.3%top 79.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Ajenti is a Linux and BSD modular server admin panel. Prior to 2.2.15, an authenticated user (using the auth_users plugin authentication method) could install a custom package even if this user is not superuser. This vulnerability is fixed in 2.2.15.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | ajenti-panel | 2.2.15 | GHSA-73jv-44c3-j5p2 |
| PyPI | ajenti-panel | 2.2.15 | PYSEC-2026-2339 |
Affected products (as reported)
Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:L/SI:L/SA:L
References
- https://github.com/ajenti/ajenti/security/advisories/GHSA-73jv-44c3-j5p2 x_refsource_CONFIRM
- https://github.com/ajenti/ajenti/releases/tag/v2.2.15 x_refsource_MISC