Vulnerability · Published Apr 2, 2026 · Assigned by GitHub_M

CVE-2026-34760vLLM: Downmix Implementation Differences as Attack Vectors Against Audio AI Models

Medium 5.9

In plain English

A medium-severity improper input validation in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.3%top 79.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before version 0.18.0, Librosa defaults to using numpy.mean for mono downmixing (to_mono), while the international standard ITU-R BS.775-4 specifies a weighted downmixing algorithm. This discrepancy results in inconsistency between audio heard by humans (e.g., through headphones/regular speakers) and audio processed by AI models (Which infra via Librosa, such as vllm, transformer). This issue has been patched in version 0.18.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.18.0GHSA-6c4r-fmh3-7rh8
PyPIvllm0.18.0PYSEC-2026-2299

Affected products (as reported)

VendorProductVersions
vllm-project vllm >= 0.5.5, < 0.18.0

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:L

References