Vulnerability · Published Apr 1, 2026 · Assigned by GitHub_M

CVE-2026-34748@payloadcms/next has Stored XSS in Admin Panel

High 8.7

In plain English

A high-severity cross-site scripting in payload from payloadcms. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.7High
Exploit odds (30 days)0.3%top 78.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Payload is a free and open source headless content management system. Prior to version 3.78.0 in @payloadcms/next, a stored Cross-Site Scripting (XSS) vulnerability existed in the admin panel. An authenticated user with write access to a collection could save content that, when viewed by another user, would execute in their browser. This issue has been patched in version 3.78.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@payloadcms/next3.78.0GHSA-mmxc-95ch-2j7c

Affected products (as reported)

VendorProductVersions
payloadcms payload < 3.78.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

References