Vulnerability · Published Apr 2, 2026 · Assigned by GitHub_M

CVE-2026-34591Poetry Has Wheel Path Traversal Which Can Lead to Arbitrary File Write

High 7.1

In plain English

A high-severity path traversal in poetry from python-poetry. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.5%top 57.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Poetry is a dependency manager for Python. From version 1.4.0 to before version 2.3.3, a crafted wheel can contain ../ paths that Poetry writes to disk without containment checks, allowing arbitrary file write with the privileges of the Poetry process. It is reachable from untrusted package artifacts during normal install flows. (Normally, installing a malicious wheel is not sufficient for execution of malicious code. Malicious code will only be executed after installation if the malicious package is imported or invoked by the user.). This issue has been patched in version 2.3.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12poetryno fix listedDEBIAN-CVE-2026-34591
Debian:13poetry2.1.2+dfsg-1+deb13u1DEBIAN-CVE-2026-34591
Debian:14poetry2.3.4-0.1DEBIAN-CVE-2026-34591
PyPIpoetry2.3.3GHSA-2599-h6xx-hpxp
PyPIpoetry2.3.3PYSEC-2026-2260
Ubuntu:22.04:LTSpoetryno fix listedUBUNTU-CVE-2026-34591
Ubuntu:24.04:LTSpoetryno fix listedUBUNTU-CVE-2026-34591
Ubuntu:25.10poetryno fix listedUBUNTU-CVE-2026-34591
Ubuntu:26.04:LTSpoetryno fix listedUBUNTU-CVE-2026-34591
Ubuntu:26.10poetryno fix listedUBUNTU-CVE-2026-34591

Affected products (as reported)

VendorProductVersions
python-poetry poetry >= 1.4.0, < 2.3.3

Weakness: CWE-22 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

References