Vulnerability · Published Aug 6, 2026 · Assigned by apache

CVE-2026-34501Apache Portable Runtime Utility: Heap buffer overflow in APR redis client

High 7.5

In plain English

A high-severity heap buffer overflow in Apache Portable Runtime Utility from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 56.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Heap-based Buffer Overflow vulnerability in Apache Portable Runtime Utility redis client. This issue affects Apache Portable Runtime Utility: from 1.6.0 through 1.6.3. Users are recommended to upgrade to version 1.6.4, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:10apr-util1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:8apr-util-bdb1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-bdb1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-devel1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-devel1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-devel1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-ldap1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-ldap1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-ldap1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-lmdb1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:10apr-util-mysql1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-mysql1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-mysql1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-odbc1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-odbc1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-odbc1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-openssl1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-openssl1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-openssl1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-pgsql1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-pgsql1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-pgsql1.6.1-23.el9_8.1ALSA-2026:66341
AlmaLinux:10apr-util-sqlite1.6.3-23.el10_2.1ALSA-2026:66392
AlmaLinux:8apr-util-sqlite1.6.1-9.el8_10.1ALSA-2026:69113
AlmaLinux:9apr-util-sqlite1.6.1-23.el9_8.1ALSA-2026:66341
Alpine:v3.21apr-util1.6.4-r0ALPINE-CVE-2026-34501
Alpine:v3.22apr-util1.6.4-r0ALPINE-CVE-2026-34501
Alpine:v3.23apr-util1.6.4-r0ALPINE-CVE-2026-34501
Alpine:v3.24apr-util1.6.4-r0ALPINE-CVE-2026-34501
Debian:12apr-util1.6.3-1+deb12u1DEBIAN-CVE-2026-34501
Debian:13apr-util1.6.3-3+deb13u1DEBIAN-CVE-2026-34501
Debian:14apr-util1.6.4-1DEBIAN-CVE-2026-34501
Rocky Linux:10apr-util0:1.6.3-23.el10_2.1RLSA-2026:66392
Rocky Linux:8apr-util0:1.6.1-9.el8_10.1RLSA-2026:69113
Rocky Linux:9apr-util0:1.6.1-23.el9_8.1RLSA-2026:66341
Ubuntu:22.04:LTSapr-util1.6.1-5ubuntu4.22.04.3USN-8719-1
Ubuntu:22.04:LTSapr-util1.6.1-5ubuntu4.22.04.3UBUNTU-CVE-2026-34501
Ubuntu:24.04:LTSapr-util1.6.3-1.1ubuntu7.1USN-8719-1
Ubuntu:24.04:LTSapr-util1.6.3-1.1ubuntu7.1UBUNTU-CVE-2026-34501
Ubuntu:26.04:LTSapr-util1.6.3-3ubuntu3.1UBUNTU-CVE-2026-34501
Ubuntu:26.04:LTSapr-util1.6.3-3ubuntu3.1USN-8719-1

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Portable Runtime Utility 1.6.0 – through 1.6.3

Weakness: CWE-122 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References