Vulnerability · Published May 19, 2026 · Assigned by GitHub_M
CVE-2026-34154Discourse has a subscription access bypass in its discourse-subscriptions plugin
Low 2.1
In plain English
A low-severity missing authorization in discourse from discourse. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities).
Official description
Discourse is an open-source discussion platform. In versions prior to 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1, a vulnerability in the discourse-subscriptions plugin allows users to gain access to subscription-gated groups without completing payment. This issue has been fixed in versions 2026.1.4, 2026.3.1, 2026.4.1 and 2026.5.0-latest.1.
Affected products (as reported)
Weakness: CWE-862 · Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/discourse/discourse/security/advisories/GHSA-pjgj-7mjq-6j7g x_refsource_CONFIRM